EtherChannel Configuration on Cisco Switches

Introduction

In this lesson, I will explain how to configure, verify, and troubleshoot EtherChannel on Cisco switches. EtherChannel technology combines multiple physical interfaces into a single logical interface, providing increased bandwidth and redundancy for inter-switch connections.

Lesson Objectives

After completing this lesson, you will be able to:

  • Understand the different EtherChannel protocols (PAgP and LACP)
  • Configure Layer 2 EtherChannel using both static and dynamic methods
  • Verify EtherChannel operation and troubleshoot common issues
  • Implement best practices for EtherChannel deployment

Prerequisites

  • Basic understanding of Cisco IOS command-line interface
  • Knowledge of switch port configuration and VLANs
  • CCNA-level networking knowledge
  • Access to two Cisco switches supporting EtherChannel (2960, 3750, or similar)
  • Console cables and Ethernet cables for connectivity

Core Lesson Content

Part 1: Understanding EtherChannel Fundamentals

Protocol Options

EtherChannel can be configured using three methods:

  • Static configuration (manual)
  • Port Aggregation Protocol (PAgP) – Cisco proprietary
  • Link Aggregation Control Protocol (LACP) – IEEE 802.3ad standard

Key Configuration Requirements

  • All ports must have:
  • Identical speed and duplex settings
  • Same native VLAN and allowed VLAN list
  • Consistent port mode (access or trunk)
  • Matching EtherChannel protocol settings

Part 2: Basic EtherChannel Configuration

Static EtherChannel Configuration

! Switch 1 Configuration
Switch1(config)# interface range gigabitethernet 1/0/1-2
Switch1(config-if-range)# channel-group 1 mode on
Switch1(config-if-range)# no shutdown

! Switch 2 Configuration
Switch2(config)# interface range gigabitethernet 1/0/1-2
Switch2(config-if-range)# channel-group 1 mode on
Switch2(config-if-range)# no shutdown

Understanding the Output:

  • channel-group 1: Creates channel-group number 1
  • mode on: Configures static EtherChannel without any protocol
  • The port-channel interface is automatically created

What to Look For:

  • Both switches should show the port-channel interface as “up/up”
  • Member interfaces should be bundled
  • No error messages in the logs

LACP Configuration

! Switch 1 Configuration
Switch1(config)# interface range gigabitethernet 1/0/3-4
Switch1(config-if-range)# channel-group 2 mode active
Switch1(config-if-range)# no shutdown

! Switch 2 Configuration
Switch2(config)# interface range gigabitethernet 1/0/3-4
Switch2(config-if-range)# channel-group 2 mode passive
Switch2(config-if-range)# no shutdown

Understanding LACP Modes:

  • active: Initiates LACP negotiation
  • passive: Responds to LACP negotiation
  • At least one side must be active

Part 3: Verification and Troubleshooting

Essential Verification Commands

Switch# show etherchannel summary
Switch# show etherchannel port-channel
Switch# show running-config interface port-channel 1
Switch# show interfaces port-channel 1

Sample Output Analysis:

Switch# show etherchannel summary
Group  Port-channel  Protocol    Ports
------+-------------+-----------+--------------------------------
1      Po1(SU)         -        Gi1/0/1(P) Gi1/0/2(P)
2      Po2(SU)        LACP      Gi1/0/3(P) Gi1/0/4(P)

Understanding the Output:

  • (SU) = Port-channel is up and in use
  • (P) = Port is bundled in port-channel
  • (I) = Port is stand-alone (not bundled)

Common Issues and Solutions

  1. Mismatched Configuration
  • Problem: Ports won’t bundle
  • Solution: Verify speed, duplex, VLANs match on all ports
  1. Protocol Mismatch
  • Problem: One side using LACP, other using PAgP
  • Solution: Ensure both switches use the same protocol
  1. Load Balancing Issues
  • Problem: Uneven traffic distribution
  • Solution: Configure appropriate load-balancing method
   Switch(config)# port-channel load-balance src-dst-mac

Practical Exercise

Lab Scenario

Configure a 4-port EtherChannel between two switches using LACP:

  1. Connect four physical links between switches
  2. Configure LACP EtherChannel
  3. Verify the configuration
  4. Test failover by disconnecting one link
  5. Monitor traffic distribution

Exercise Steps

! Switch 1
Switch1(config)# interface range gi1/0/1-4
Switch1(config-if-range)# switchport mode trunk
Switch1(config-if-range)# channel-group 1 mode active
Switch1(config-if-range)# no shutdown

! Switch 2
Switch2(config)# interface range gi1/0/1-4
Switch2(config-if-range)# switchport mode trunk
Switch2(config-if-range)# channel-group 1 mode active
Switch2(config-if-range)# no shutdown

Key Takeaways

  • EtherChannel provides bandwidth aggregation and redundancy
  • Always verify configuration requirements before implementation
  • Use dynamic protocols (LACP/PAgP) when possible for automatic negotiation
  • Regular verification ensures optimal performance

Next Steps

  1. Learn about Layer 3 EtherChannel configuration
  2. Explore advanced load-balancing methods
  3. Study Multi-chassis EtherChannel (MEC) concepts
  4. Practice different failure scenarios

Quick Reference Commands

! Configuration Commands
channel-group <number> mode {on | active | passive | auto | desirable}
port-channel load-balance {src-mac | dst-mac | src-dst-mac}

! Verification Commands
show etherchannel summary
show etherchannel port-channel
show spanning-tree

Verification Checklist

  • All ports show the correct channel-group assignment
  • Port-channel interface is up/up
  • Load balancing configuration is appropriate
  • Spanning-tree shows port-channel as a single logical interface
  • No error messages in the system logs

Subscribe to Ping Labz

Don’t miss out on the latest issues. Sign up now to get access to the library of members-only issues.
jamie@example.com
Subscribe